Topic: pzthon 3.2 incompatibility

Dear M. Johansen,
I appreciate your program enormously, which I use in teaching. I do not have the ressources (nor the competence) to build it from source. Unfortunately, the plugins are set up to require precisely version 3.1 of python and not any version at least 3.1. I work with the latest (beta, even) version of python, having come to my senses (ie having taken python as my main language) after the 2to3 overhaul, so I certainly don't expect any backwards compatibility nor any support for ancient python <3. But anything that works with 3.1 should also work with 3.2.

Could you not, please, change the buld so that plugins work with a system-wide
python 3.x (x >= 1) installation?
I am willing to work on the code of the .py files in the trunk distribution, but the many links to external libraries (including the non-tkinter interface) are beyond my capabilities.
Best wishes, thanks for your consideration, and happy summer,


Re: pzthon 3.2 incompatibility

The problem is that Graph has to be compiled against a specific version of Python. It is not possible to support several different versions of Python without creating different binary versions of Graph for every version of Python, and I want to avoid that.

I tried upgrading to Python 3.2 some time ago, but the Swig library used in Graph did not support Python 3.2. I think that might have been fixed now, so I plan to try again.

Re: pzthon 3.2 incompatibility

I have now updated Graph to use Python 3.2 as scripting engine. It will no longer be possible to use Python 3.1. The change is in the beta version of Graph 4.4 build 504.