Topic: Double integration and commas

Greetings Ivan,

I have to evaluate the integral of a 2-variable function over a range on both variables : that's a double integral, which Graph doesn't seem to support without script-coding. In avoiding script-coding, I work with integrating one variable at a time :

Integrating over variable "s" from 0 to "b", using a fixed "t" value :

So I created a point series with this (shortened) list of points where I can vary the value of t :

0    integrate(TestFunction(s,0.00),s,0,b)
0.01    integrate(TestFunction(s,0.01),s,0,b)
0.02    integrate(TestFunction(s,0.02),s,0,b)
0.03    integrate(TestFunction(s,0.03),s,0,b)

Using the Area Calculator in Graph, I'll be able to know the numerical value of the double integral.

So here come a few questions :
1) I can't seem to simply write "x" instead of the 0.00, or 0.01 and so on, in the "y" column. That would make it simple. Is there a way to do that?
2) Since I have a hundred integrations to write down in the list (going over "t" from 0 to 1 in 0.01 increments), I used Excel to increment the "t" numbers, and used the concatenate function to patch the beginning and end of the formula. When I get to pasting the table in Graph, Graph automatically changes all commas to points, effectively breaking the formulas. Is there a way to avoid this?
3) do you have a tool ready for numerical results on a double definite integral?

Thank you!

Re: Double integration and commas

Hello Ivan,

Would you have a work-around for my first two questions?

The third question can be dismissed.

Thank you!

Re: Double integration and commas

I actually expected double integration to just work, but to my surprise I can see that it is a little broken. However it seems to be just a little and not totally broken. For example the following seems to work:

integrate(b*integrate(x*a, a, 0, 2), b, 8, 9) 

Here it seems to be important that b comes before the second integration. This should of course not matter and I will look into fixing this bug.

If you still cannot make it work, please specify the function you want to plot as I am a little unsure what exactly it is you are trying to do.

In the Edit|Options dialog, you can change Custom decimal separator to a dot to prevent Graph from changing commas to dots when pasting into Graph.