Topic: Arrows on both ends of x-axis and y-axis on startup

I looked up an old post about getting the arrows to show up on the x-axis and y-axis by using the python console using:

Graph.Axes.xAxis.ShowNegativeArrow=True
Graph.Axes.yAxis.ShowNegativeArrow=True

Once this was achieved, I tried to save the settings of the axis as default (so that the next time I start graph the arrows on both ends of the axes would show up). However, the arrows did not show up on startup.

Is there a way to have the arrows on both ends of each axis show up on startup?

Thank you

Re: Arrows on both ends of x-axis and y-axis on startup

That is my mistake. The setting got reset by the Axes dialog. It was not supposed to do that. I have fixed it now in the beta version of Graph 4.5, which you can find at http://www.padowan.dk/beta/

Re: Arrows on both ends of x-axis and y-axis on startup

Thanks for fixing that! I downloaded 4.5 v571 just now, and unfortunately, the arrows on the negative ends of the axes still don't show.

Re: Arrows on both ends of x-axis and y-axis on startup

Maybe I wasn't clear. You still need to enter the two lines in the Python console:
Graph.Axes.xAxis.ShowNegativeArrow=True
Graph.Axes.yAxis.ShowNegativeArrow=True

After pressing F5 you can see the negative arrows. What I fixed was that you can now use Save as default in the Edit|Axes dialog afterwards to store the setting so you don't need to do this every time..

Re: Arrows on both ends of x-axis and y-axis on startup

Gotcha! Thanks again for making that possible.

-Marco

Re: Arrows on both ends of x-axis and y-axis on startup

There seems to be some problems in build 571, which make it crash. It should be fixed now, so I suggest you download build 572 instead.